Static route چیست و پیاده سازی آن بر روی میکروتیک

route یعنی چه؟

هنگامی که شما در یک شبکه محلی تعدادی سیستم را به یک سوییچ وصل می کنید و به همه آنها IP اختصاص می دهید یک شبکه محلی ساده را پیاده سازی کرده اید.
حالا اگر نیاز باشه کامپیوتری دارای آی پی خارج محدوده کلاس آی پی های داده شده، داشته باشد باید از یک روتر استفاده کنیم تا ارتباط بین این دو رو بر قرار کنه .
من در این پست روتینگ رو به صورت شبکه ای با 2 روتر میکروتیک و دو شبکه مجزا متصل به این روتر ها برای شما توضیح میدم.

“مثال این پست از سایت wiki.mikrotik.com گرفته شده .”

فرض رو بر این میگذاریم که دو شبکه کجزا داریم و قراره اینها به هم وصل بشوند . با یک مثال ساده موضوع روتینگ ایستا ( static routing ) رو توضیح میدم : فرض کنید شما می خواهید به مقصدی خاص بروید و فقط یک نفر را برای پرسیدن آدرس سراغ دارید . ابتده به اطراف خود نگاه میکنید تا ببینید مقصد مورد نظر رو می بینید یا نه ؟ در صورت رویت مستقیم به آن مراجعه می کنید ، اگر نه از تنها شخص نزدیک خود می پرسید ! اگر آن شخص در دیدرس خود مقصد شما رو مشاهده کرد ، مقصد را به شما نشان می دهد در غیر اینصورت شما را ارجاع می دهد به نفر بعد از خود تا سوال خود را از نفر بعدی بپرسید ، این ماجرا آنقدر ادامه میابد که در نهایت به مقصد مورد نظر می رسید.به عبارتی در نهایت باید کسی باشد که مقصد مورد نظر شما را در دیدرس خود ببیند.

در مثال بالا افرادی که از اونها سوال می کنید روتر ها هستند
ارتباط بین افراد که شما را هدایت می کنند به وسیله Default Gateway می باشد
منظور از دیدرس هم قرار گرفتن Subnet Mask مقصد شما در رنج روتر نهایی میباشد

حالا با استفاده از عکس فوق ما می خواهیم این دو شبکه رو که با دو روتر به هم متصل هستند رو  کانفیگ کنیم.
همونطوری که می بینید در شبکه سمت راست از یک کامپیوتر و ارتباط اون به یکی از interface های روتر که به شکل وایرلس متصل شده ( وایرلس بودن و نبودن در این مثال اهمیتی ندارد ) و دارای IP های 192.168.22.0/24 هستند و در شبکه سمت چپ نیز یک کامپیوتر به یکی از Interface های روتر متصل شده و کلاس IP 192.168.20.0/24 در ارتباطاتشان استفاده شده. این دو روتر از Interface دیگری به یکدیگر متصل شده اند و IPهای 192.168.21.1 و 192.168.21.2 به آنها اختصاص داده شده.
حالا با داشتن اطلاعات فوق باید مسیر گذر پکت ها از شبکه سمت راست به شبکه سمت چپ رو بنویسیم و همینطور بلعکس تا یک ارتباط کامل بر قرار بشه.
اول در روتر 1 که روی اینترفیس هاش از قبل IP ها رو ست کردیم این دستورات رو اجرا می کنیم :

/ip route add dst-address=192.168.22.0/24 gateway=192.168.21.2

با دستور بالا ما به روتر اعلام میکنیم برای پیدا کردن IPهای 192.168.22.0/24 به IP روتر 192.168.21.2 مراجعه کنه و همینطور در روتر شماره 2 مینویسیم :

/ip route add dst-address=192.168.20.0/24 gateway=192.168.21.1

که در این دستور هم به روتر شماره 2 مسیر دسترسی به IPهای 192.168.20.0/24 رو ،مراجعه به روتر 192.168.21.1 اعلام می کنیم

الآن اگر از روی هر کدوم از سیستم ها می توانید به سیستم شبکه دیگر ارتباط بر قرار کنید.
شما تونستید 2 شبکه مجزا رو به هم وصل کنید!

اگر فرض کنیم IP های به کار رفته Valid باشند و شما از طریق روتر شماره یک به اینترنت وصل باشید و روتر بعد از شما مثلاً آی پی 123.45.6.78 باشه و IP روتر شما که بر روی Interface متصل به اینترنت است 123.45.6.79 باشد کافیه با وارد کردن این خط در روتر شماره یک Client شماره 1 می تواند به اینترنت متصل شود :

/ip route add dst-address=0.0.0.0/0 gateway=123.45.6.78

در این دستور یعنی تمامی درخواست های دیگر به این روتر انتقال پیدا کنه.

——————–
دوستتون دارم
عرفان

  1. بسیار ممنون.
    مشکلم حل شد

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>