EOIP Tunnel

بنا به درخواست بازدید کنندگان عزیز در این پست نحوه راه اندازی یک ارتباط تانلی از نوع( EOIP Tunnel ( Ethernet Over IP رو توضیح میدم .
اینکه چطور این ارتباط رو بر قرار کنیم و از قابلیت های خاص اون استفاده کنیم.
EOIP Tunnel یک نوع تانل بسیار کاربردی است که توسط router OS میکروتیک ایجاد و پشتیبانی میشه ،همونطور که میدونید این نوع ارتباط هم نوعی از ارتباط IPIP هست که با کمی تغییر در پکت های ارسالی کاربرد های بیشتری پیدا کرد. در تانل EOIP تمام ترافیک های اترنت انتقال پیدا می کند و Broadcasting اعمال می شود.
به بیان ساده تر یعنی میتوان با EOIP Tunnel  یک کابل از سوئیچ شبکه سایت A به سوئیچ شبکه سایت B وصل کرد !

به گفته خود wiki.mikrotik.com این ارتباط برای

  • ایجاد Bridge بین دو شبکه LAN بر روی بستر اینترنت
  • ایجاد Bridge بین دو شبکه LAN بر روی یک تانل Encrypt شده
  • و همینطور Bridge دو شبکه LAN بر روی ارتباطات wireless
خب دیگه وقتشه شروع کنیم به کانفیگ روترمون!
ابتدا باید IP های public ما همدیگه رو ببینن و ارتباط برقرار باشه و بعد در سمت سایت 1 و 2 یک خط دستور رو می نویسیم با این تفاوت که در سایت 1 remote address رو IP روتر سایت 2 و در سایت 2 remote address رو IP روتر سایت 1 قرار میدیم.
/interface eoip add arp=enabled disabled=no l2mtu=65535 local-address=0.0.0.0 mac-address=02:F8:1F:70:D5:1E mtu=1500 name=EOIP-site1 remote-address=18.105.16.23 tunnel-id=20
 گزینه Tunnel ID برای جدا کردن تانل ها به صورت VLAN هستند و برای تفکیک تانل ها به کار برده میشه و به یاد داشته باشید که ارتباط تانل ها فقط در صورت برار بودن ID اونها امکان پذیره !
توی سایت 2 هم این کد رو با کمی تغییر که گفته شد وارد می کنیم :
/interface eoip add arp=enabled disabled=no l2mtu=65535 local-address=0.0.0.0 mac-address=02:F8:1F:70:D5:1E mtu=1500 name=EOIP-site1 remote-address=90.15.6.180 tunnel-id=20
دیدید که به راحتی این تانل بر قرار شد !
حالا اگر بخواهیم شبکه زیر مجموعه هر کدام از روتر ها رو با شبکه روتر مقابل در یک LAN قرار بدیم کافیه این interface جدیدی که ساختیم رو با interface سمت شبکه داخلی در یک Bridge قرار بدیم.
راستی ! نیازی هم به IP دادن نیست ! چون عملاً داره به عنوان یه کابل رابط بین دو شبکه کار میکنه . و هیچ کانفیگ دیگه ای نیاز نیست
موفق باشید
——————
دوستتون دارم
عرفان

 

  1. سلام
    و ممنون از آموزشهای خوب شما آقا عرفان ممنون و استفاده کردم منتظر اموزشهای بعدی شما در مورد میکروتیک هستیم

    • سلام دوست عزیز
      ممنونم ازت
      همین پست های شماست که منو مشتاق تر میکنه تا فعالیتم رو بیشتر کنم
      به زودی اموزشهای جدیدتر میزارم
      یه خورده هم از این تانل ها خارج میشم

  2. اقا عرفان عزیز سلام و ممنون که وقت میذارین و زحمت میکشین. من الان بین دو نقطه در مشهد و تهران که سرویس اینترانت دارند تانل eoip زدم و ارتباط برقراره. میشه بفرمایید امنیت این تانل چقدره؟ و آیا همین کانفیگ امنیت کافی رو داره یا نه؟
    ممنون. دوستتون دارم.

    • سلام هادی عزیز
      این نوع تانل خودش به تنهایی هیچ cryptingی روی دیتا ایجاد نمیکنه
      یعنی مثل یه شبکه اینترنت که همه پکت ها اسنیف میتونن بشن اینم اسنیف میشه
      اگه میخوای مثل /\np امنیت پکت داشته باشی باید یه ارتباط /\np یا ss t p بزنی بعد روی اون ای پی ها تانل بزنی

  3. yani 2 ta ip valid mikhad vase in kar?

  4. mishe lotf konid emailetoono bedid ba chat rahnamaim koni?sakhtare shabakamoon pichidas vaghan komak ehtiaj daram..mamnoon misham komakam konid

    • سلام
      به صورت چت بعید میدونم بتونم کمکی بکنم
      چون معمولا آنلاین رو نرم افزار های IM نیستم
      بهترین کار اینه که توپولوژی موجود و هدفتون رو واسم به صورت عکس ایمیل کنین
      ایمیل من :erfan@3rfan.com
      یا config@mikrotikblog.com

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>